"Cannot find any subscriptions" error message in the Azure portal or the Azure Account Center

When you attempt to sign in to the Azure portal or the Azure Account Center, you might get an error message that says "Cannot find any subscriptions." This article provides solutions for this issue.

Symptom

When you attempt to sign in to the Azure portal or the Azure Account Center, you might get an error message that says "Cannot find any subscriptions."

Cause

This issue occurs if you choose the wrong directory or the account does not have sufficient permissions.

Solutions

Scenario 1: You receive the error message in the Azure portal

To resolve this issue:

  1. In the Azure portal, at the upper right, select the account to ensure that you have selected the correct Azure Directory.

    Select the Azure Directory.

  2. If you have selected the correct Azure Directory, but you still get the error message, check to ensure that you have added the account as the owner.

Scenario 2: You receive the error message in the Azure Account Center

Check to ensure that the account you are using is an account administrator. If you need to learn who the account administrator is, do the following:

  1. Log on to the subscriptions view in Azure portal.

    Select the subscription in Azure portal

  2. Select the subscription that you want to check and then, under Settings, view the information.

  3. Select Properties. The account administrator for the subscription will be shown in the “Account administrator” box.
    Select the subscription in Azure portal

Contact Support.

If you still need help to resolve your issue, contact our support team.