Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
This article describes the causes and solutions for 403006 DeviceMaximumActiveFileUploadLimitExceeded errors.
Symptoms
Your file upload request fails with the error code 403006 and a message "Number of active file upload requests cannot exceed 10".
Cause
Each device client is limited to 10 concurrent file uploads.
You can easily exceed the limit if your device doesn't notify IoT Hub when file uploads are completed. This problem is commonly caused by an unreliable device side network.
Solution
Ensure the device can promptly notify IoT Hub file upload completion. Then, try reducing the SAS token TTL for file upload configuration.
Next steps
To learn more about file uploads, see Upload files with IoT Hub and Configure IoT Hub file uploads using the Azure portal.