Windows shows “checking file system” when booting an Azure VM

This article describes the “Checking file system” error that you may encounter when you boot a Windows Virtual Machine (VM) in Microsoft Azure.

Symptom

A Windows VM doesn't start. When you check the boot screenshots in Boot diagnostics, you see that the Check Disk process (chkdsk.exe) is running with one of the following messages:

  • Scanning and repairing drive (C:)
  • Checking file system on C:

Cause

If an NTFS error is found in the file system, Windows will check and repair the consistency of the disk at the next restart. Usually this happens if the VM had any unexpected restart, or if the VM shutdown process was abruptly interrupted.

Solution

Tip

If you have a recent backup of the VM, you may try restoring the VM from the backup to fix the boot problem.

Windows will boot normally after the Check Disk process is completed. If the VM is stuck in the Check Disk process, try to run the Check Disk on the VM offline:

  1. Take a snapshot of the OS disk of the affected VM as a backup. For more information, see Snapshot a disk.

  2. Attach the OS disk to a recovery VM.

  3. On the recovery VM, run Check Disk on the attached OS disk. In the following sample, the driver letter of the attached OS disk is E:

    chkdsk E: /f
    
  4. After the Check Disk completes, detach the disk from the recovery VM, and then re-attach the disk to the affected VM as an OS disk. For more information, see Troubleshoot a Windows VM by attaching the OS disk to a recovery VM.

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.