Azure Stack Hub 已知问题

本文列出了 Azure Stack Hub 版本中的已知问题。 每当发现新的问题,此列表就会更新。

若要访问不同版本的已知问题,请使用左侧目录上方的版本选择器下拉列表。

重要

在应用更新之前,请先查看本部分。

重要

如果 Azure Stack Hub 实例落后于两个以上的更新,则认为它不符合。 必须至少更新到最低支持版本才能获得支持

更新

有关已知的 Azure Stack Hub 更新问题,请参阅排查 Azure Stack Hub 中的更新问题

在 AKS/ACR 的更新前检查期间更新到 2102 失败

  • 适用:此问题适用于计划升级到 2102 或应用任何修补程序的 Azure Kubernetes 服务 (AKS) 和 Azure 容器注册表 (ACR) 个人预览版客户。
  • 补救措施:在更新到 2102 之前或在更新到 2102 之后应用任何修补程序之前卸载 AKS 和 ACR。 请在卸载这些服务后重启更新。
  • 发生次数:任何安装了 ACR 或 AKS 的缩放单元都会遇到此故障。

门户

管理订阅

  • 适用于:此问题适用于所有支持的版本。
  • 原因:两个管理订阅类型“计量”和“消耗”已经被禁用,不应该使用。 如果其中有资源,则会生成警报,直到删除这些资源为止。
  • 补救措施:如果有资源在这两个订阅上运行,请在用户订阅中重新创建这些资源。
  • 发生次数:通用

网络

虚拟网络网关

负载均衡器

IPv6 按钮在“添加前端 IP 地址”上可用

  • 适用于:此问题适用于版本 2008 及更高版本。
  • 原因:IPv6 按钮在负载均衡器的“添加前端 IP 地址”选项上可见。 这些按钮处于禁用状态,无法选择。
  • 发生次数:通用

启用浮动 IP 时的后端端口和前端端口

  • 适用于:此问题适用于所有支持的版本。
  • 原因:根据负载平衡规则,启用浮动 IP 时,前端端口和后端端口需要保持一致。 此行为是设计使然。
  • 发生次数:通用

计算

Syslog 管道中无警报

  • 适用于:此问题适用于版本 2102。
  • 原因:此版本已禁用客户的警报模块(具体取决于警报的 Syslog)。 对于此版本,已修改运行状况和监视管道,以减少依赖项和服务要求的数量。 因此,新服务不会向 Syslog 管道发出警报。
  • 补救措施:无。
  • 发生次数:通用

使用情况

基础结构备份的错误状态

  • 适用于:此问题适用于版本 2102。
  • 原因:刷新状态本身时,基础结构备份作业可能会显示错误的状态(失败或成功)。 这不会影响备份数据的一致性,但如果发生实际故障,可能会导致混淆。
  • 补救措施:此问题会在 2102 的下一修补程序中修复。

更新

有关已知的 Azure Stack Hub 更新问题,请参阅排查 Azure Stack Hub 中的更新问题

更新无法将包 Microsoft.AzureStack.Compute.Installer 安装到 CA VM

  • 适用于:此问题适用于所有支持的版本。
  • 原因:在更新过程中,进程会锁定需要复制到 CA VM 的新内容。 更新失败时,会释放锁。
  • 补救措施:继续更新。
  • 发生次数:罕见

门户

管理订阅

  • 适用于:此问题适用于所有支持的版本。
  • 原因:不应使用版本 1804 中引入的两个管理订阅。 这两种订阅类型为“计量订阅”和“消耗订阅”。
  • 补救措施:如果有资源在这两个订阅上运行,请在用户订阅中重新创建这些资源。
  • 发生次数:通用

网络

网络安全组

DenyAllOutbound 规则导致 VM 部署失败

  • 适用于:此问题适用于所有支持的版本。

  • 原因:VM 创建期间无法在 NSG 中创建到 Internet 的显式 DenyAllOutbound 规则,因为这会使 VM 部署所需的通信无法完成。 它还会拒绝两个部署 VM 所需的基本 IP:DHCP IP:169.254.169.254 和 DNS IP:168.63.129.16。

  • 补救措施:VM 创建期间允许出站流量流向 Internet,并在 VM 创建完成后修改 NSG 以阻止所需的流量。

  • 发生次数:通用

虚拟网络网关

负载均衡器

在特定情况下将流量定向到一个后端 VM 的负载均衡器

  • 适用于:此问题适用于所有支持的版本。
  • 原因:在负载均衡器上启用“会话相关性”时,2 元组哈希使用 PA IP(物理地址 IP)而不是分配给 VM 的专用 IP。 如果定向到负载均衡器的流量通过 VPN 到达,或者,如果所有客户端 VM(源 IP)位于同一节点上并且启用了会话相关性,则所有流量都将定向到一个后端 VM。
  • 发生次数:通用

IPv6 按钮在“添加前端 IP 地址”上可用

  • 适用于:此问题适用于 2008 版本。
  • 原因:在创建公共负载均衡器的前端 IP 配置时,IPv6 按钮是可见的,且已启用。 这是一个门户上的外观问题。 Azure Stack Hub 目前不支持 IPv6。
  • 发生次数:通用

在启用浮动 IP 的情况下,后端端口和前端端口必须相同

  • 适用于:此问题适用于所有版本。
  • 原因:根据负载平衡规则,启用浮动 IP 时,前端端口和后端端口需要保持一致。 此行为是设计使然。
  • 发生次数:通用

计算

停止解除分配 VM 会导致删除 MTU 配置

  • 适用于:此问题适用于所有支持的版本。
  • 原因:对 VM 执行 停止-解除分配 会导致删除 VM 上的 MTU 配置。 此行为与 Azure 中不一致。
  • 发生次数:通用

更新

有关已知的 Azure Stack Hub 更新问题,请参阅排查 Azure Stack Hub 中的更新问题

更新无法将包 Microsoft.AzureStack.Compute.Installer 安装到 CA VM

  • 适用于:此问题适用于所有支持的版本。
  • 原因:在更新过程中,进程会锁定需要复制到 CA VM 的新内容。 更新失败时,会释放锁。
  • 补救措施:继续更新。
  • 发生次数:罕见

门户

管理订阅

  • 适用于:此问题适用于所有支持的版本。
  • 原因:不应使用版本 1804 中引入的两个管理订阅。 这两种订阅类型为“计量订阅”和“消耗订阅”。
  • 补救措施:如果有资源在这两个订阅上运行,请在用户订阅中重新创建这些资源。
  • 发生次数:通用

网络

网络安全组

如果 NIC 未附加到运行中的 VM,则无法删除 NSG

  • 适用于:此问题适用于所有支持的版本。
  • 原因:如果取消关联 NSG 和未附加到运行中 VM 的 NIC,则该对象的更新 (PUT) 操作会在网络控制器层失败。 NSG 将在网络资源提供程序层(而不是网络控制器上)更新,因此 NSG 转变为失败状态。
  • 补救措施:将与 NSG 相关联的 NIC 附加到运行中的 VM,然后取消与 NSG 的关联,或者删除与 NSG 关联的所有 NIC。
  • 发生次数:通用

DenyAllOutbound 规则导致 VM 部署失败

  • 适用于:此问题适用于所有支持的版本。
  • 原因:VM 创建期间无法在 NSG 中创建到 Internet 的显式 DenyAllOutbound 规则,因为这会使 VM 部署所需的通信无法完成。
  • 补救措施:VM 创建期间允许出站流量流向 Internet,并在 VM 创建完成后修改 NSG 以阻止所需的流量。
  • 发生次数:通用

虚拟网络网关

负载均衡器

在特定情况下将流量定向到一个后端 VM 的负载均衡器

  • 适用于:此问题适用于所有支持的版本。
  • 原因:在负载均衡器上启用“会话相关性”时,2 元组哈希使用 PA IP(物理地址 IP)而不是分配给 VM 的专用 IP。 如果定向到负载均衡器的流量通过 VPN 到达,或者,如果所有客户端 VM(源 IP)位于同一节点上并且启用了会话相关性,则所有流量都将定向到一个后端 VM。
  • 发生次数:通用

公共 IP 处于失败状态

  • 适用于:此问题适用于所有支持的版本。
  • 原因:无法更改与负载均衡器关联的公共 IP 的 IdleTimeoutInMinutes 值。 该操作会将公共 IP 置于失败状态。
  • 补救措施:若要使公共 IP 恢复成功状态,请将引用公共 IP 的负载均衡器规则上的 IdleTimeoutInMinutes 值更改回原始值(默认值为 4 分钟)。
  • 发生次数:通用

计算

停止-解除分配 VM 将导致 MTU 配置

  • 适用于:此问题适用于所有支持的版本。
  • 原因:对 VM 执行 停止-解除分配 会导致删除 VM 上的 MTU 配置。 此行为与 Azure 中不一致。
  • 发生次数:通用

使用门户部署 Standard_DS2_v2 大小的虚拟机规模集时遇到的问题

  • 适用于:此问题适用于 2005 版本。
  • 原因:门户 bug 导致创建 Standard_DS2_v2 大小的规模集失败。
  • 补救措施:使用 PowerShell 或 CLI 部署此虚拟机规模集 VM 大小。

在 Ubuntu Server 20.04 中使用 VM 扩展时遇到的问题

  • 适用于:此问题适用于 Ubuntu Server 20.04 LTS。
  • 原因:某些 Linux 发行版已转换为 Python 3.8,并完全删除了 Python 的旧版 /usr/bin/python 入口点。 已转换到 Python 3.x 的 Linux 发行版用户在尝试将这些扩展部署到自己的 VM 之前,必须确保存在旧版 /usr/bin/python 入口点。 否则,扩展部署可能会失败。
  • 补救措施:请按照在启用 Python 3 的 Linux Azure 虚拟机系统中使用 VM 扩展时遇到的问题中的解决步骤操作,但请跳过步骤 2,因为 Azure Stack Hub 没有“运行命令”功能。

门户上的 NVv4 VM 大小

  • 适用于:此问题适用于 2002 及更高版本。
  • 原因:完成 VM 创建体验后,你将看到 VM 大小:NV4as_v4。 如果客户拥有基于 AMD MI25 的 Azure Stack Hub GPU 预览版所需的硬件,那么这些客户可以成功部署 VM。 所有其他客户将无法使用此 VM 大小部署 VM。
  • 补救措施:按照设计为 Azure Stack Hub GPU 预览版做准备。

已消耗的计算配额

  • 适用于:此问题适用于所有支持的版本。
  • 原因:创建新虚拟机时,可能会收到一则错误消息,例如“此订阅在此位置的区域 vCPU 总数已达到上限。此订阅使用了所有可用的 50 个区域 vCPU”。 这表示可用的核心配额总计已达到上限。
  • 补救措施:请求操作员提供配额更高的附加计划。 编辑当前计划的配额不起作用,也不会反映提高的配额。
  • 发生次数:罕见

VM 概述边栏选项卡未显示正确的计算机名称

  • 适用于:此问题适用于所有版本。
  • 原因:在概述边栏选项卡中查看 VM 的详细信息时,计算机名称显示为“(不可用)”。 这种行为是专为从专用磁盘/磁盘快照创建的 VM 设计的,也会针对市场映像出现。
  • 补救措施:在“设置”下查看“属性”边栏选项卡。

虚拟机规模集

在 4 节点的 Azure Stack Hub 环境中进行修补和更新时出现故障

  • 适用于:此问题适用于所有支持的版本。
  • 原因:在包含 3 个容错域的可用性集中创建 VM 以及创建虚拟机规模集实例失败,在一个 4 节点 Azure Stack Hub 环境中进行更新时出现 FabricVmPlacementErrorUnsupportedFaultDomainSize 错误。
  • 补救措施:可以在包含 2 个容错域的可用性集中成功创建单一 VM。 但是,在 4 节点 Azure Stack Hub 部署中进行更新时,仍然不能创建规模集实例。

存储

保留期恢复为 0

  • 适用于:此问题适用于版本 2002 和 2005。
  • 原因:如果在保留期设置中指定非 0 的时间段,则它将在 2002 或 2005 更新期间恢复为 0(此设置的默认值)。 这个 0 天的设置将在更新完成后立即生效,从而导致所有现有已删除的存储帐户和任何即将新删除的存储帐户立即不予保留,并标记为需要进行定期垃圾回收(每小时运行一次)。
  • 补救措施:将保留期手动指定为正确的时间段。 在指定新的保留期之前已进行垃圾回收的任何存储帐户都不可恢复。

资源提供程序

SQL/MySQL

  • 适用于:此问题适用于版本 2002。
  • 原因:如果标记包含 SQL 资源提供程序 (RP) 版本 1.1.33.0 或更早版本,则在更新标记时,不会加载 SQL/MySQL 的边栏选项卡。
  • 补救措施:将 RP 更新到版本 1.1.47.0。

应用服务

  • 适用于:此问题适用于版本 2002。
  • 原因:如果标记包含应用服务资源提供程序 (RP) 版本 1.7 和更早版本,则在更新标记时,不会加载应用服务的边栏选项卡。
  • 补救措施:将 RP 更新到版本 2002 Q2。

PowerShell

安装 Az 模块时引发错误

  • 适用于:此问题适用于 2002 及更高版本
  • 原因:安装模块时引发错误。 错误消息的开头为:Register-PacakgeSource : A parameter cannot be found that matches parameter name. 'PackageManagementProvider'.,错误消息也可能包含以下文本:PackageManagement\Install-Package : Cannot convert value "2.0.1-preview" to type "System.Version". Error: "Input string was not in a correct format."
  • 补救措施:请在同一会话中运行以下 cmdlet:
    Install-Module PowershellGet -MinimumumVersion 2.3.0 -Force
    关闭会话并启动权限提升的新 PowerShell 会话。
  • 发生次数:通用

安装 Az 模块时,错误地引发“需要管理员权限”错误

  • 适用于:此问题适用于 2002 及更高版本
  • 原因:在提升的提示符下安装模块时,会引发错误。 错误指出“Administrator rights required”。
  • 补救措施:关闭会话并启动权限提升的新 PowerShell 会话。 请确保会话中没有加载现有的 Az. Accounts 模块。
  • 发生次数:通用

后续步骤