本文介绍在与 Azure HDInsight 群集交互时出现的问题的故障排除步骤和可能的解决方案。
问题
Apache Ambari UI 可以访问,但 UI 显示几乎所有服务都已关闭,所有主机都显示检测信号丢失。
原因
在大多数情况下,这是 Ambari 服务器未在活动头节点上运行的问题。 检查哪个头节点是活动头节点,并确保 Ambari 服务器在正确的头节点上运行。 请勿手动启动 Ambari 服务器,让故障转移控制器服务负责在正确的头节点上启动 Ambari 服务器。 重新启动活动头节点以强制进行故障转移。
网络问题也可能导致此问题。 从每个群集节点,看看是否可以 ping 通 headnodehost
。 在极少数情况下,任何群集节点都无法连接到 headnodehost
:
$>telnet headnodehost 8440
... No route to host
解决方法
通常,重新启动活动头节点会缓解此问题。 如果未缓解,请与 HDInsight 支持团队联系。
后续步骤
如果你的问题未在本文中列出,或者无法解决问题,请访问以下渠道之一获取更多支持:
- 如果需要更多帮助,可以从 Azure 门户提交支持请求。 从菜单栏中选择“支持” ,或打开“帮助 + 支持” 中心。