方案: Azure HDInsight 中的连接重置后出现存储异常

本文介绍在与 Azure HDInsight 群集交互时出现的问题的故障排除步骤和可能的解决方案。

问题

无法创建新的 Apache HBase 表。

原因

在表截断过程中出现了存储连接问题。 已在 HBase 元数据表中删除表项。 只保留了一个 Blob 文件,并删除了所有其他文件。

存储中没有名为 /hbase/data/default/ThatTable 的文件夹 Blob。 WASB 驱动程序发现存在上述 Blob 文件,因此不允许它创建名为 /hbase/data/default/ThatTable 的任何 Blob(因为它假定父文件夹已存在),因此创建表将会失败。

解决方法

  1. 从 Apache Ambari UI 重启活动的 HMaster。 这样一来,两个备用 HMaster 中的一个将成为活动的 HMaster,而新的活动 HMaster 将重新加载元数据表信息。 因此,在 HMaster UI 中看不到 already-deleted 表。

  2. 可以通过 Cloud Explorer 等 UI 工具,或运行类似于 hdfs dfs -ls /xxxxxx/yyyyy 的命令来查找孤立的 Blob 文件。 运行 hdfs dfs -rmr /xxxxx/yyyy 可删除该 Blob。 例如,hdfs dfs -rmr /hbase/data/default/ThatTable/ThatFile

现在,可以在 HBase 中创建同名的新表。

后续步骤

如果你的问题未在本文中列出,或者无法解决问题,请访问以下渠道以获取更多支持:

  • 如果需要更多帮助,可以从 Azure 门户提交支持请求。 从菜单栏中选择“支持” ,或打开“帮助 + 支持” 中心。 有关更多详细信息,请参阅如何创建 Azure 支持请求。 Microsoft Azure 订阅中带有对订阅管理和计费支持的访问权限,技术支持通过 Azure 支持计划之一提供。