500xxx Internal errors

This article describes the causes and solutions for 500xxx Internal errors.

Symptoms

Your request to IoT Hub fails with an error that begins with 500 and/or some sort of "server error". Some possibilities are:

  • 500001 ServerError: IoT Hub ran into a server-side issue.

  • 500008 GenericTimeout: IoT Hub couldn't complete the connection request before timing out.

  • ServiceUnavailable (no error code): IoT Hub encountered an internal error.

  • InternalServerError (no error code): IoT Hub encountered an internal error.

Cause

There can be a number of causes for a 500xxx error response. In all cases, the issue is most likely transient. While the IoT Hub team works hard to maintain the SLA, small subsets of IoT Hub nodes can occasionally experience transient faults. When your device tries to connect to a node that's having issues, you receive this error.

Solution

To mitigate 500xxx errors, issue a retry from the device. To automatically manage retries, make sure you use the latest version of the Azure IoT SDKs. For best practice on transient fault handling and retries, see Transient fault handling. If the problem persists, check Resource Health and Azure Status to see if IoT Hub has a known problem. You can also use the manual failover feature. If there are no known problems and the issue continues, contact support for further investigation.