排查 Azure 自动化帐户问题

本文介绍使用 Azure 自动化帐户时可能会遇到的问题的解决方案。 有关自动化帐户的常规信息,请参阅 Azure 自动化帐户身份验证概述

方案:将 GUID 用作帐户名时无法创建自动化帐户

问题

当你使用 GUID 作为帐户名称创建自动化帐户时,你会遇到错误。

原因

accountid 是一个区域中所有自动化帐户的唯一标识符,当帐户名称是 GUID 时,我们将自动化帐户 ID 和名称都保留为 GUID。 在这种情况下,当你创建一个新的自动化帐户并指定一个 GUID(作为帐户名称)时,如果它与任何现有的自动化 accountid 冲突,你会遇到错误。

例如,当你尝试创建名称为 8a2f48c1-9e99-472c-be1b-dcc11429c9ff 的自动化帐户时,如果该区域中的所有自动化帐户中已经存在一个自动化帐户 ID,则帐户创建将失败,你将看到以下错误:

   {

   "code": "BadRequest",

   "message": Automation account already exists with this account id. AccountId: 8a2f48c1-9e99-472c-be1b-dcc11429c9ff. 

   }

解决方法

确保使用新名称创建自动化帐户。

场景:无法为订阅注册自动化资源提供程序

问题

在自动化帐户中使用管理功能(例如更新管理)时,遇到以下错误:

Error details: Unable to register Automation Resource Provider for subscriptions:

原因

未在订阅中注册自动化资源提供程序。

解决方法

若要注册自动化资源提供程序,请在 Azure 门户中执行以下步骤:

  1. 在浏览器中转到 Azure 门户

  2. 转到“订阅”,选择你的订阅。

  3. 在“设置”下,选择“资源提供程序”。

  4. 在资源提供程序列表中,验证是否注册了 Microsoft.Automation 资源提供程序。

  5. 如果未列出提供程序,请按照解决资源提供程序注册错误中所述的方式进行注册。

后续步骤

如果本文未解决你的问题,请尝试通过以下渠道之一获取更多支持: