支持的 Service Fabric 版本Supported Service Fabric versions

请确保群集始终运行受支持的 Azure Service Fabric 版本。Make sure your cluster is always running a supported Azure Service Fabric version. 在公告新版 Service Fabric 的发布日期以后,至少还要过 60 天我们才会结束对旧版本的支持。A minimum of 60 days after we announce the release of a new version of Service Fabric, support for the previous version ends. 可以在 Service Fabric 团队博客中找到有关新版本的公告。You'll find announcements of new releases on the Service Fabric team blog.

对于给定版本的 Service Fabric 运行时,可以使用指定版本或较旧版本的 SDK/NuGet 包。For a given version of the Service Fabric runtime you can use the specified or older versions of the SDK/NuGet packages. 较新版本的包不受支持,并且在针对较旧群集时可能会产生问题,因为它们可能具有这些环境不支持的功能或协议更改。Newer versions of the packages are not supported and may have issues targeting older clusters as they may have feature or protocol changes not supported by those environments.

若要详细了解如何使群集始终运行受支持的 Service Fabric 版本,请参阅以下文档:Refer to the following documents for details on how to keep your cluster running a supported Service Fabric version:

不支持的版本Unsupported Versions

5.7 和 6.3.63 以下版本之间的版本升级警报。Upgrade Alert for versions between 5.7 and below 6.3.63.*

为了提高安全性和可用性,Azure 基础结构将进行更改,这可能会影响 Service Fabric 客户。To improve security and availability, Azure infrastructure will make a change that may affect Service Fabric customers. 从 5.7 到 6.3 的不受支持版本上的所有 Service Fabric 群集都会受影响。All Service Fabric clusters on unsupported versions from 5.7 to 6.3. are impacted. 为了应对此更改,需要更新 Service Fabric 运行时,该运行时已可用于所有区域中所有受支持的 Service Fabric 版本。Addressing the change requires an update to the Service Fabric runtime, which is already available for all supported Service Fabric versions in all regions.

我们请求并建议你在 2021 年 1 月 19 日之前采取行动升级到最新的受支持版本,以避免服务中断。如果你有支持计划且需要技术帮助,请通过 Azure 支持渠道联系我们(方法是创建针对 Azure Service Fabric 的支持请求)并在支持票证中提及此上下文。We request and recommend taking action to upgrade to the latest supported versions by Jan 19,2021 to avoid service disruptions If you have a support plan and you need technical help, please reach out to us via Azure support channels by opening a support request for Azure Service Fabric and mention this context in the support ticket.

未升级到受支持的版本时受到的影响Impact If NOT Upgraded to supported versions

如果你在 2021 年 1 月 19 日之前尚未升级到下述受支持的版本之一,则在从 5.7 到 6.3.63.* 的不受支持的版本上运行的 Azure Service Fabric 群集将无法启动,变得不可用。Azure Service Fabric clusters which run on unsupported versions from 5.7 to 6.3.63.* will not be able to come up and will be unavailable if you have not upgraded to one of below supported versions by January 19,2021.

所需的操作Required Action

请升级到下面列出的受支持的 Service Fabric 版本,以避免与此更改相关的停机或功能丢失。Upgrade to the Service Fabric supported versions listed below to prevent downtime or loss of functionality related to this change. 请确保你的群集至少运行这些版本,以防止你的环境中出现问题。Please ensure that your clusters are running at least these versions to prevent issues in your environment.

支持的 Service Fabric 运行时版本Supported Service Fabric Runtime Versions

如果你未使用下面列出的受支持的 Service Fabric 版本,请升级到这些版本中的一个(这些版本已经包含必要的更改),以防止群集停机。If you are on NOT on the below listed supported versions of Service Fabric, please upgrade to one of these versions which already contain the necessary changes to prevent downtime to cluster. 注意: 所有 7.2 发行版都包括必要的更改。Note: All release versions of 7.2 includes the necessary changes.

OSOS 当前群集中的 Service Fabric 运行时Current Service Fabric runtime in the cluster CU/修补程序版本CU/Patch release
WindowsWindows 7.0.*7.0.* 7.0.478.95907.0.478.9590
WindowsWindows 7.1.*7.1.* 7.1.503.95907.1.503.9590
WindowsWindows 7.2.*7.2.* 7.2.*7.2.*
Ubuntu 16Ubuntu 16 7.0.*7.0.* 7.0.472.17.0.472.1
Linux Ubuntu 16.04Linux Ubuntu 16.04 7.1.*7.1.* 7.1.455.17.1.455.1
Linux Ubuntu 18.04Linux Ubuntu 18.04 7.1.*7.1.* 7.1.455.18047.1.455.1804
Linux Ubuntu 16.04Linux Ubuntu 16.04 7.2.*7.2.* 7.2.*7.2.*
Linux Ubuntu 18.04Linux Ubuntu 18.04 7.2.*7.2.* 7.2.*7.2.*

针对低于 6.3 的版本的升级提醒Upgrade alert for versions later than 6.3

为了提高安全性和可用性,Azure 基础结构已进行更改,这可能会影响 Service Fabric 客户。To improve security and availability, Azure infrastructure has made a change that might affect Service Fabric customers. 此更改会影响使用容器的开放网络模式并运行版本 6.3 到 7.0 或 7.0 之后不兼容的受支持版本的所有 Service Fabric 群集。This change will affect all Service Fabric clusters that use Open networking mode for containers and run versions 6.3 to 7.0 or incompatible supported versions later than 7.0. 我们提供了一个 Service Fabric 运行时更新,它适用于所有区域中所有受支持的 Service Fabric 版本。An update to the Service Fabric runtime is available for all supported Service Fabric versions in all regions.

如果未升级到受支持的版本If you don't upgrade to a supported version

如果 2021 年 1 月 19 日之前没有升级到受支持的版本,在高于 6.3 的未更改版本上运行的 Azure Service Fabric 群集会出现功能丢失或服务中断的情况。Azure Service Fabric clusters that run on unchanged versions later than 6.3 will experience loss of functionality or service disruptions if they weren't upgraded to a supported version by January 19, 2021.

  • 对于运行的 Service Fabric 版本高于 6.3 的群集,如果未使用开放网络功能,则群集会保持正常运行状态。For clusters running a version of Service Fabric greater than 6.3 NOT using Open Networking feature, the cluster will remain up.

  • 对于运行的 Service Fabric 版本高于6.3 的群集,如果使用了容器的开放网络功能,则该群集可能会变得不可用并停止运行,这可能会导致工作负荷的服务中断。For clusters running a version of Service Fabric greater than 6.3 and use Open Networking feature for Containers ,the cluster could become unavailable and will cease functioning which could cause service interruptions for your workloads.

  • 对于运行的 Windows 版本介于 7.0 到 7.0.466(包括这两个版本)之间且 Windows OS 已启用 Windows 容器功能的群集(注意:Linux 版本 7.0.457、7.0.464 和 7.0.465 不受影响),For clusters running Windows Versions between 7.0 and 7.0.466 (both versions included) and the Windows OS has the Windows Containers Feature enabled. NOTE: Linux versions 7.0.457, 7.0.464 and 7.0.465 are NOT impacted.

    • 影响是:群集会停止运行,这可能会导致工作负荷的服务中断。Impact: The cluster will cease functioning which could cause service interruptions for your workloads.

必需的操作Required action

若要防止停机或功能丢失,请确保群集运行的是以下版本之一。To prevent downtime or loss of functionality, ensure that your clusters are running one of the following versions.

表中的 Service Fabric 版本包含防止功能丢失所需的更改。The versions of Service Fabric in the table contain the necessary changes to prevent loss of functionality. 请确保你使用的是这些版本之一。Make sure you're using one of these versions.

备注

所有 7.2 发行版都包括必要的更改。All release versions of 7.2 include the necessary changes.

OSOS 当前群集中的 Service Fabric 运行时Current Service Fabric runtime in the cluster CU/修补程序版本CU/Patch release
WindowsWindows 7.0.*7.0.* 7.0.478.95907.0.478.9590
WindowsWindows 7.1.*7.1.* 7.1.503.95907.1.503.9590
WindowsWindows 7.2.*7.2.* 7.2.*7.2.*
Linux Ubuntu 16.04Linux Ubuntu 16.04 7.0.*7.0.* 7.0.472.17.0.472.1
Linux Ubuntu 16.04Linux Ubuntu 16.04 7.1.*7.1.* 7.1.455.17.1.455.1
Linux Ubuntu 18.04Linux Ubuntu 18.04 7.1.*7.1.* 7.1.455.18047.1.455.1804
Linux Ubuntu 16.04Linux Ubuntu 16.04 7.2.*7.2.* 7.2.*7.2.*
Linux Ubuntu 18.04Linux Ubuntu 18.04 7.2.*7.2.* 7.2.*7.2.*

支持的版本Supported versions

下表列出了 Service Fabric 版本及其支持结束日期。The following table lists the versions of Service Fabric and their support end dates.

群集中的 Service Fabric 运行时Service Fabric runtime in the cluster 可以直接从群集版本升级Can upgrade directly from cluster version 兼容的 SDK 或 NuGet 包版本Compatible SDK or NuGet package version 结束支持End of support
5.3.121 之前的所有群集版本All cluster versions before 5.3.121 5.1.158.*5.1.158.* 低于或等于版本 2.3Less than or equal to version 2.3 2017 年 1 月 20 日January 20, 2017
5.3.*5.3.* 5.1.158.*5.1.158.* 低于或等于版本 2.3Less than or equal to version 2.3 2017 年 2 月 24 日February 24, 2017
5.4.*5.4.* 5.1.158.*5.1.158.* 低于或等于版本 2.4Less than or equal to version 2.4 2017 年 5 月 10 日May 10, 2017
5.5.*5.5.* 5.4.164.*5.4.164.* 低于或等于版本 2.5Less than or equal to version 2.5 2017 年 8 月 10 日August 10,2017
5.6.*5.6.* 5.4.164.*5.4.164.* 低于或等于版本 2.6Less than or equal to version 2.6 2017 年 10 月 13 日October 13,2017
5.7.*5.7.* 5.4.164.*5.4.164.* 低于或等于版本 2.7Less than or equal to version 2.7 2017 年 12 月 15 日December 15, 2017
6.0.*6.0.* 5.6.205.*5.6.205.* 版本 2.8 或更低版本Less than or equal to version 2.8 2018 年 3 月 30 日March 30, 2018
6.1.*6.1.* 5.7.221.*5.7.221.* 版本 3.0 或更低版本Less than or equal to version 3.0 2018 年 7 月 15日July 15, 2018
6.2.*6.2.* 6.0.232.*6.0.232.* 版本 3.1 或更低版本Less than or equal to version 3.1 2018 年 10 月 26日October 26, 2018
6.3.*6.3.* 6.1.480.*6.1.480.* 版本 3.2 或更低版本Less than or equal to version 3.2 2019 年 3 月 31 日March 31, 2019
6.4.*6.4.* 6.2.301.*6.2.301.* 版本 3.3 或更低版本Less than or equal to version 3.3 2019 年 9 月 15 日September 15, 2019
6.5.*6.5.* 6.4.617.*6.4.617.* 低于或等于版本 3.4Less than or equal to version 3.4 2020 年 8 月 1 日August 1, 2020
7.0.466.*7.0.466.* 6.4.664.*6.4.664.* 低于或等于版本 4.0Less than or equal to version 4.0 2021 年 1 月 31 日January 31, 2021
7.0.466.*7.0.466.* 6.5.*6.5.* 低于或等于版本 4.0Less than or equal to version 4.0 2021 年 1 月 31 日January 31, 2021
7.0.470.*7.0.470.* 7.0.466.*7.0.466.* 低于或等于版本 4.0Less than or equal to version 4.0 2021 年 1 月 31 日January 31, 2021
7.0.472.*7.0.472.* 7.0.466.*7.0.466.* 低于或等于版本 4.0Less than or equal to version 4.0 2021 年 1 月 31 日January 31, 2021
7.0.478.*7.0.478.* 7.0.466.*7.0.466.* 低于或等于版本 4.0Less than or equal to version 4.0 2021 年 1 月 31 日January 31, 2021
7.1.409.*7.1.409.* 7.0.466.*7.0.466.* 低于或等于版本 4.1Less than or equal to version 4.1 2021 年 3 月 31 日March 31, 2021
7.1.417.*7.1.417.* 7.0.466.*7.0.466.* 低于或等于版本 4.1Less than or equal to version 4.1 2021 年 3 月 31 日March 31, 2021
7.1.428.*7.1.428.* 7.0.466.*7.0.466.* 低于或等于版本 4.1Less than or equal to version 4.1 2021 年 3 月 31 日March 31, 2021
7.1.456.*7.1.456.* 7.0.466.*7.0.466.* 低于或等于版本 4.1Less than or equal to version 4.1 2021 年 3 月 31 日March 31, 2021
7.1.458。*7.1.458.* 7.0.466.*7.0.466.* 低于或等于版本 4.1Less than or equal to version 4.1 2021 年 3 月 31 日March 31, 2021
7.1.459.*7.1.459.* 7.0.466.*7.0.466.* 低于或等于版本 4.1Less than or equal to version 4.1 2021 年 3 月 31 日March 31, 2021
7.1.503.*7.1.503.* 7.0.466.*7.0.466.* 低于或等于版本 4.1Less than or equal to version 4.1 2021 年 3 月 31 日March 31, 2021
7.1.510.*7.1.510.* 7.0.466.*7.0.466.* 低于或等于版本 4.1Less than or equal to version 4.1 2021 年 3 月 31 日March 31, 2021
7.2.413.*7.2.413.* 7.0.470.*7.0.470.* 低于或等于版本 4.2Less than or equal to version 4.2 当前版本,因此无结束日期Current version, so no end date
7.2.432.*7.2.432.* 7.0.470.*7.0.470.* 低于或等于版本 4.2Less than or equal to version 4.2 当前版本,因此无结束日期Current version, so no end date
7.2.433.*7.2.433.* 7.0.470.*7.0.470.* 低于或等于版本 4.2Less than or equal to version 4.2 当前版本,因此无结束日期Current version, so no end date
7.2.445.*7.2.445.* 7.0.470.*7.0.470.* 低于或等于版本 4.2Less than or equal to version 4.2 当前版本,因此无结束日期Current version, so no end date
7.2.452.*7.2.452.* 7.0.470.*7.0.470.* 低于或等于版本 4.2Less than or equal to version 4.2 当前版本,因此无结束日期Current version, so no end date

支持的操作系统Supported operating systems

下表列出了支持的 Service Fabric 版本所支持的操作系统。The following table lists the supported operating systems for the supported Service Fabric versions.

操作系统Operating system 支持的最低 Service Fabric 版本Earliest supported Service Fabric version
Windows Server 2012 R2Windows Server 2012 R2 所有版本All versions
Windows Server 2016Windows Server 2016 所有版本All versions
Windows Server 1709Windows Server 1709 6.06.0
Windows Server 1803Windows Server 1803 6.46.4
Windows Server 1809Windows Server 1809 6.4.654.95906.4.654.9590
Windows Server 2019Windows Server 2019 6.4.654.95906.4.654.9590
Linux Ubuntu 16.04Linux Ubuntu 16.04 6.06.0
Linux Ubuntu 18.04Linux Ubuntu 18.04 7.17.1

支持的版本名称Supported version names

下表列出了 Service Fabric 的版本名称以及相应的版本号。The following table lists the version names of Service Fabric and their corresponding version numbers.

版本名称Version name Windows 版本号Windows version number Linux 版本号Linux version number
5.3 RTO5.3 RTO 5.3.121.94945.3.121.9494 不适用Not applicable
5.3 CU15.3 CU1 5.3.204.94945.3.204.9494 不适用Not applicable
5.3 CU25.3 CU2 5.3.301.95905.3.301.9590 不适用Not applicable
5.3 CU35.3 CU3 5.3.311.95905.3.311.9590 不适用Not applicable
5.4 CU25.4 CU2 5.4.164.94945.4.164.9494 不适用Not applicable
5.5 CU15.5 CU1 5.5.216.05.5.216.0 不适用Not applicable
5.5 CU25.5 CU2 5.5.219.05.5.219.0 不适用Not applicable
5.5 CU35.5 CU3 5.5.227.05.5.227.0 不适用Not applicable
5.5 CU45.5 CU4 5.5.232.05.5.232.0 不适用Not applicable
5.6 RTO5.6 RTO 5.6.204.94945.6.204.9494 不适用Not applicable
5.6 CU25.6 CU2 5.6.210.94945.6.210.9494 不适用Not applicable
5.6 CU35.6 CU3 5.6.220.94945.6.220.9494 不适用Not applicable
5.7 RTO5.7 RTO 5.7.198.94945.7.198.9494 不适用Not applicable
5.7 CU45.7 CU4 5.7.221.94945.7.221.9494 不适用Not applicable
6.0 RTO6.0 RTO 6.0.211.94946.0.211.9494 6.0.120.16.0.120.1
6.0 CU16.0 CU1 6.0.219.94946.0.219.9494 6.0.127.16.0.127.1
6.0 CU26.0 CU2 6.0.232.94946.0.232.9494 6.0.133.16.0.133.1
6.1 CU16.1 CU1 6.1.456.94946.1.456.9494 6.1.183.16.1.183.1
6.1 CU26.1 CU2 6.1.467.94946.1.467.9494 6.1.185.16.1.185.1
6.1 CU36.1 CU3 6.1.472.94946.1.472.9494 不适用Not applicable
6.1 CU46.1 CU4 6.1.480.94946.1.480.9494 6.1.187.16.1.187.1
6.2 RTO6.2 RTO 6.2.269.94946.2.269.9494 6.2.184.16.2.184.1
6.2 CU16.2 CU1 6.2.274.94946.2.274.9494 6.2.191.16.2.191.1
6.2 CU26.2 CU2 6.2.283.94946.2.283.9494 6.2.194.16.2.194.1
6.2 CU36.2 CU3 6.2.301.94946.2.301.9494 6.2.199.16.2.199.1
6.3 RTO6.3 RTO 6.3.162.94946.3.162.9494 6.3.119.16.3.119.1
6.3 CU16.3 CU1 6.3.176.94946.3.176.9494 6.3.124.16.3.124.1
6.3 CU16.3 CU1 6.3.187.94946.3.187.9494 6.3.129.16.3.129.1
6.4 RTO6.4 RTO 6.4.617.95906.4.617.9590 6.4.625.16.4.625.1
6.4 CU26.4 CU2 6.4.622.95906.4.622.9590 不适用Not applicable
6.4 CU36.4 CU3 6.4.637.95906.4.637.9590 6.4.634.16.4.634.1
6.4 CU46.4 CU4 6.4.644.95906.4.644.9590 6.4.639.16.4.639.1
6.4 CU56.4 CU5 6.4.654.95906.4.654.9590 6.4.649.16.4.649.1
6.4 CU66.4 CU6 6.4.658.95906.4.658.9590 不适用Not applicable
6.4 CU76.4 CU7 6.4.664.95906.4.664.9590 6.4.661.16.4.661.1
6.4 CU86.4 CU8 6.4.670.95906.4.670.9590 不适用Not applicable
6.5 RTO6.5 RTO 6.5.639.95906.5.639.9590 6.5.435.16.5.435.1
6.5 CU16.5 CU1 6.5.641.95906.5.641.9590 6.5.454.16.5.454.1
6.5 CU26.5 CU2 6.5.658.95906.5.658.9590 6.5.460.16.5.460.1
6.5 CU36.5 CU3 6.5.664.95906.5.664.9590 6.5.466.16.5.466.1
6.5 CU56.5 CU5 6.5.676.95906.5.676.9590 6.5.467.16.5.467.1
7.0 RTO7.0 RTO 7.0.457.95907.0.457.9590 7.0.457.17.0.457.1
7.0 CU27.0 CU2 7.0.464.95907.0.464.9590 7.0.464.17.0.464.1
7.0 CU37.0 CU3 7.0.466.95907.0.466.9590 7.0.465.17.0.465.1
7.0 CU47.0 CU4 7.0.470.95907.0.470.9590 7.0.469.17.0.469.1
7.0 CU67.0 CU6 7.0.472.95907.0.472.9590 7.0.471.17.0.471.1
7.0 CU97.0 CU9 7.0.478.95907.0.478.9590 7.0.472.17.0.472.1
7.1 RTO7.1 RTO 7.1.409.95907.1.409.9590 7.1.410.17.1.410.1
7.1 CU17.1 CU1 7.1.417.95907.1.417.9590 7.1.418.17.1.418.1
7.1 CU27.1 CU2 7.1.428.95907.1.428.9590 7.1.428.17.1.428.1
7.1 CU37.1 CU3 7.1.456.95907.1.456.9590 7.1.452.17.1.452.1
7.1 CU57.1 CU5 7.1.458.95907.1.458.9590 7.1.454.17.1.454.1
7.1 CU67.1 CU6 7.1.459.95907.1.459.9590 7.1.455.17.1.455.1
7.1 CU87.1 CU8 7.1.503.95907.1.503.9590 7.1.508.17.1.508.1
7.1 CU107.1 CU10 7.1.510.95907.1.510.9590 NANA
7.2 RTO7.2 RTO 7.2.413.95907.2.413.9590 NANA
7.2 CU27.2 CU2 7.2.432.95907.2.432.9590 7.2.431.17.2.431.1
7.2 CU37.2 CU3 7.2.433.95907.2.433.9590 不适用Not applicable
7.2 CU47.2 CU4 7.2.445.95907.2.445.9590 7.2.447.17.2.447.1
7.2 CU57.2 CU5 7.2.452.95907.2.452.9590 7.2.454.17.2.454.1