使用针对 Visual Studio 的 Data Lake 工具连接到 Azure HDInsight 并运行 Apache Hive 查询Use Data Lake Tools for Visual Studio to connect to Azure HDInsight and run Apache Hive queries

了解如何使用用于 Visual Studio 的 Microsoft Azure Data Lake 和流分析工具(也称为 Data Lake 工具)连接到 Azure HDInsight 中的 Apache Hadoop 群集并提交 Hive 查询。Learn how to use Microsoft Azure Data Lake and Stream Analytics Tools for Visual Studio (also called Data Lake Tools) to connect to Apache Hadoop clusters in Azure HDInsight and submit Hive queries.

有关使用 HDInsight 的详细信息,请参阅 HDInsight 简介HDInsight 入门For more information about using HDInsight, see Introduction to HDInsight and Get started with HDInsight.

有关连接到 Apache Storm 群集的详细信息,请参阅使用适用于 Visual Studio 的 Data Lake 工具为 Apache Storm 开发 C# 拓扑For more information about connecting to an Apache Storm cluster, see Develop C# topologies for Apache Storm by using the Data Lake tools for Visual Studio.

可以使用用于 Visual Studio 的 Data Lake 工具访问 Azure Data Lake Analytics 和 HDInsight。You can use Data Lake Tools for Visual Studio to access Azure Data Lake Analytics and HDInsight.

先决条件Prerequisites

若要完成本文并使用用于 Visual Studio 的 Data Lake 工具,需要具备以下项目:To complete this article and use Data Lake Tools for Visual Studio, you need the following items:

安装用于 Visual Studio 的 Data Lake 工具Install Data Lake Tools for Visual Studio

按照相应的说明安装适用于所用 Visual Studio 版本的 Data Lake 工具:Follow the appropriate instructions to install Data Lake Tools for your version of Visual Studio:

  • 对于 Visual Studio 2017 或 Visual Studio 2019:For Visual Studio 2017 or Visual Studio 2019:

    在安装 Visual Studio 期间,请确保包含“Azure 开发”工作负荷或“数据存储和处理”工作负荷。 During Visual Studio installation, make sure you include the Azure development workload or the Data storage and processing workload.

    对于现有的 Visual Studio 安装,请转到 IDE 菜单栏,选择“工具” > “获取工具和功能”打开 Visual Studio 安装程序。 For existing Visual Studio installations, go to the IDE menu bar, and select Tools > Get Tools and Features to open Visual Studio Installer. 在“工作负荷”选项卡中,至少选择“Azure 开发”工作负荷(在“Web 和云”下)或“数据存储和处理”工作负荷(在“其他工具集”下)。 In the Workloads tab, select at least the Azure development workload (under Web & Cloud) or the Data storage and processing workload (under Other Toolsets).

    工作负荷选择,Visual Studio 安装程序

  • 对于 Visual Studio 2015:For Visual Studio 2015:

    下载 Data Lake 工具Download Data Lake Tools. 请选择与 Visual Studio 版本匹配的 Data Lake 工具版本。Choose the version of Data Lake Tools that matches your version of Visual Studio.

更新用于 Visual Studio 的 Data Lake 工具Update Data Lake Tools for Visual Studio

接下来,请确保将 Data Lake 工具更新到最新版本。Next, make sure you update Data Lake Tools to the most recent version.

  1. 打开 Visual Studio。Open Visual Studio.

  2. 在“开始”窗口中,选择“继续但无需代码”。 In the Start window, select Continue without code.

  3. 在 Visual Studio IDE 菜单栏中,选择“扩展” > “管理扩展”。 In the Visual Studio IDE menu bar, choose Extensions > Manage Extensions.

  4. 在“管理扩展”对话框中,展开“更新”节点。 In the Manage Extensions dialog box, expand the Updates node.

  5. 如果可用更新列表中包含“Azure Data Lake 和流分析工具”,请将其选中。 If the list of available updates includes Azure Data Lake and Stream Analytic Tools, select it. 然后选择其“更新”按钮。 Then select its Update button. 在“下载并安装”对话框显示并消失后,Visual Studio 会将“Azure Data Lake 和流分析工具”扩展添加到更新计划中。 After the Download and Install dialog box appears and disappears, Visual Studio adds the Azure Data Lake and Stream Analytic Tools extension to the update schedule.

  6. 关闭所有 Visual Studio 窗口。Close all Visual Studio windows. 此时会显示“VSIX 安装程序”对话框。 The VSIX Installer dialog box appears.

  7. 选择“许可证”以阅读许可条款,然后选择“关闭”以返回到“VSIX 安装程序”对话框。 Select License to read the license terms, then select Close to return to the VSIX Installer dialog box.

  8. 选择“修改”。 Select Modify. 随即会开始安装扩展更新。Installation of the extension update begins. 片刻之后,对话框将会更改,显示已完成修改。After a while, the dialog box changes to show that it's done making modifications. 选择“关闭”,然后重启 Visual Studio 以完成安装。 Select Close, and then restart Visual Studio to complete the installation.

Note

只能使用 Data Lake 工具 2.3.0.0 或更高版本连接到交互式查询群集,然后运行交互式 Hive 查询。You can use only Data Lake Tools version 2.3.0.0 or later to connect to Interactive Query clusters and run interactive Hive queries.

连接到 Azure 订阅Connect to Azure subscriptions

可以使用适用于 Visual Studio 的 Data Lake 工具连接到 HDInsight 群集,执行一些基本管理操作,以及运行 Hive 查询。You can use Data Lake Tools for Visual Studio to connect to your HDInsight clusters, do some basic management operations, and run Hive queries.

Note

有关连接到常规 Hadoop 群集的信息,请参阅如何使用 Visual Studio 编写和提交 Hive 查询For information about connecting to a generic Hadoop cluster, see How to write and submit Hive queries using Visual Studio.

连接到 Azure 订阅Connect to an Azure subscription

若要连接到 Azure 订阅,请执行以下操作:To connect to your Azure subscription:

  1. 打开 Visual Studio。Open Visual Studio.

  2. 在“开始”窗口中,选择“继续但无需代码”。 In the Start window, select Continue without code.

  3. 在 IDE 菜单栏中,选择“视图” > “服务器资源管理器”。 In the IDE menu bar, choose View > Server Explorer.

  4. 在“服务器资源管理器”中右键单击“Azure”并选择“连接到 Microsoft Azure 订阅”,然后完成身份验证过程。 In Server Explorer, right-click Azure, select Connect to Microsoft Azure Subscription, and complete the authentication process. 在“服务器资源管理器”中,展开“Azure” > “HDInsight”查看现有 HDInsight 群集的列表。 From Server Explorer, expand Azure > HDInsight to view a list of existing HDInsight clusters.

  5. 如果没有任何群集,请使用 Azure 门户、Azure PowerShell 或 HDInsight SDK 创建一个群集。If you don't have any clusters, create one by using the Azure portal, Azure PowerShell, or the HDInsight SDK. 有关详细信息,请参阅在 HDInsight 中设置群集For more information, see Set up clusters in HDInsight.

    HDInsight 群集列表,服务器资源管理器,Visual Studio

  6. 展开 HDInsight 群集。Expand an HDInsight cluster. 群集包含“Hive 数据库”的节点、默认存储帐户、链接的其他任何存储帐户,以及“Hadoop 服务日志”。 The cluster contains nodes for Hive Databases, a default storage account, any additional linked storage accounts, and Hadoop Service Log. 可以进一步展开条目。You can further expand the entities.

连接到 Azure 订阅后,可以执行以下任务。After you've connected to your Azure subscription, you can do the following tasks.

从 Visual Studio 连接到 AzureConnect to Azure from Visual Studio

若要从 Visual Studio 连接到 Azure 门户,请执行以下操作:To connect to the Azure portal from Visual Studio:

  1. 在“服务器资源管理器”中,展开“Azure” > “HDInsight”并选择你的群集。 In Server Explorer, expand Azure > HDInsight and select your cluster.

  2. 右键单击某个 HDInsight 群集,并选择“在 Azure 门户中管理群集”。 Right-click an HDInsight cluster, and select Manage Cluster in Azure portal.

从 Visual Studio 提出问题和反馈Offer questions and feedback from Visual Studio

通过 Visual Studio 提问和/或提供反馈:To ask questions and/or provide feedback from Visual Studio:

  1. 在服务器资源管理器中,选择“Azure” > “HDInsight”。 From Server Explorer, choose Azure > HDInsight.

  2. 右键单击“HDInsight”,并选择“MSDN 论坛”以提问,或选择“提供反馈”以提供反馈。 Right-click HDInsight and select either MSDN Forum to ask questions, or Give Feedback to give feedback.

Note

目前唯一可以链接的 HDInsight 群集类型为 Hive 类型。Currently the only type of HDInsight cluster you can link to is a Hive type.

若要链接 HDInsight 群集:To link an HDInsight cluster:

  1. 右键单击“HDInsight”,然后选择“链接 HDInsight 群集”显示“链接 HDInsight 群集”对话框。 Right-click HDInsight, and then select Link a HDInsight Cluster to display the Link a HDInsight Cluster dialog box.

  2. https://<cluster name>.azurehdinsight.cn 格式输入连接 URLEnter a Connection Url in the form https://<cluster name>.azurehdinsight.cn. 转到另一字段时,“群集名称”中会自动填充该 URL 的群集名称部分。 The Cluster Name automatically fills in with the cluster name portion of your URL when you go to another field. 输入用户名密码,然后选择“下一步”。 Then enter a Username and Password, and select Next.

    链接群集,HDInsight,Visual Studio

  3. 选择“完成”。 Select Finish. 如果群集链接成功,该群集随即会列在“HDInsight”节点下。 If the cluster linking is successful, the cluster is then listed under the HDInsight node.

若要更新已链接的群集,请右键单击该群集并选择“编辑”。 To update a linked cluster, right-click the cluster and select Edit. 然后可以更新群集信息。You can then update the cluster information.

编辑已链接的群集,HDInsight,Visual Studio

浏览链接的资源Explore linked resources

在“服务器资源管理器”中,可以看到默认存储帐户和任何链接的存储帐户。From Server Explorer, you can see the default storage account and any linked storage accounts. 如果展开默认存储帐户,则可以看到存储帐户中的容器。If you expand the default storage account, you can see the containers on the storage account. 默认存储帐户和默认容器将处于标记状态。The default storage account and the default container are marked.

服务器资源管理器中“适用于 Visual Studio 的 Data Lake 工具”链接资源

右键单击某个容器,然后选择“查看容器”以查看该容器的内容。 Right-click a container and select View Container to view the container's contents. 打开容器后,可以使用工具栏按钮来刷新内容列表、上传 Blob删除选定的 Blob打开 Blob,以及下载(“另存为”)选定的 Blob。 After opening a container, you can use the toolbar buttons to Refresh the content list, Upload Blob, Delete selected blobs, Open Blob, and download (Save As) selected blobs.

容器列表和 Blob 操作,HDInsight 群集,Visual Studio

运行交互式 Apache Hive 查询Run interactive Apache Hive queries

Apache Hive 是构建于 Hadoop 之上的数据仓库基础结构。Apache Hive is a data warehouse infrastructure that's built on Hadoop. Hive 用于数据汇总、查询和分析。Hive is used for data summarization, queries, and analysis. 可以使用用于 Visual Studio 的 Data Lake 工具从 Visual Studio 运行 Hive 查询。You can use Data Lake Tools for Visual Studio to run Hive queries from Visual Studio. 有关 Hive 的详细信息,请参阅 Azure HDInsight 中的 Apache Hive 和 HiveQL 是什么?For more information about Hive, see What is Apache Hive and HiveQL on Azure HDInsight?.

Azure HDInsight 中的 Interactive Query 使用 Apache Hive 2.1 中的 Hive on LLAPInteractive Query in Azure HDInsight uses Hive on LLAP in Apache Hive 2.1. Interactive Query 为在存储的大型数据集上进行的复杂数据仓库样式查询带来了交互性。Interactive Query brings interactivity to complex, data warehouse-style queries on large, stored datasets. 相较于传统的 Hive 批处理作业,在 Interactive Query 中运行 Hive 查询的速度要快得多。Running Hive queries on Interactive Query is much faster than traditional Hive batch jobs.

Note

仅当连接到 HDInsight 交互式查询群集时,才能运行交互式 Hive 查询。You can run interactive Hive queries only when you connect to an HDInsight Interactive Query cluster.

也可使用用于 Visual Studio 的 Data Lake 工具来查看 Hive 作业中的内容。You can also use Data Lake Tools for Visual Studio to see what’s inside a Hive job. 用于 Visual Studio 的 Data Lake 工具可收集和显示某些 Hive 作业的 Yarn 日志。Data Lake Tools for Visual Studio collects and surfaces the Yarn logs of certain Hive jobs.

在“服务器资源管理器”中,选择“Azure” > “HDInsight”并选择你的群集。 From Server Explorer, choose Azure > HDInsight and select your cluster. 后续部分所述的操作将在“服务器资源管理器”中的此节点着手。 This node is the starting point in Server Explorer for the sections to follow.

查看 hivesampletableView hivesampletable

所有 HDInsight 群集都有一个名为 hivesampletable 的默认示例 Hive 表。All HDInsight clusters have a default sample Hive table called hivesampletable.

在群集中,选择“Hive 数据库” > “默认” > “hivesampletable”。 From your cluster, choose Hive Databases > default > hivesampletable.

  • 若要查看 hivesampletable 架构:To view the hivesampletable schema:

    展开“hivesampletable”。 Expand hivesampletable. 此时会显示 hivesampletable 列的名称和数据类型。The names and data types of the hivesampletable columns are shown.

  • 若要查看 hivesampletable 数据:To view the hivesampletable data:

    右键单击“hivesampletable”并选择“查看前 100 行”。 Right-click hivesampletable, and select View Top 100 Rows. 包含 100 条结果的列表将显示在“Hive 表: hivesampletable”窗口中。 The list of 100 results appears in the Hive Table: hivesampletable window. 此操作相当于使用 Hive ODBC 驱动程序运行以下 Hive 查询:This action is equivalent to running the following Hive query by using the Hive ODBC driver:

    SELECT * FROM hivesampletable LIMIT 100

    可以通过更改“行数”来自定义行计数;可以从下拉列表中选择 50、100、200 或 1000 行。 You can customize the row count by changing Number of rows; you can choose 50, 100, 200, or 1000 rows from the drop-down list.

创建 Hive 表Create Hive tables

若要创建 Hive 表,可以使用 GUI,也可以使用 Hive 查询。To create a Hive table, you can use the GUI or you can use Hive queries. 有关使用 Hive 查询的信息,请参阅创建并运行 Hive 查询For information about using Hive queries, see Create and run Hive queries.

  1. 在群集中,选择“Hive 数据库” > “默认”。 From your cluster, choose Hive Databases > default.

  2. 右键单击“默认”并选择“创建表”。 Right-click default, and select Create Table.

  3. 配置该表。Configure the table.

  4. 选择“创建表”按钮以提交创建新 Hive 表的作业。 Select the Create Table button to submit the job, which creates the new Hive table.

    “创建表”窗口,Hive,HDInsight 群集,Visual Studio

创建并运行 Hive 查询Create and run Hive queries

可以使用两个选项来创建并运行 Hive 查询:You have two options for creating and running Hive queries:

  • 创建临时查询Create ad-hoc queries
  • 创建 Hive 应用程序Create a Hive application

创建临时查询Create an ad-hoc query

若要创建并运行临时查询:To create and run an ad-hoc query:

  1. 右键单击要运行查询的群集,然后选择“编写 Hive 查询”。 Right-click the cluster where you want to run the query, and select Write a Hive Query.

  2. 输入 Hive 查询。Enter a Hive query.

    Hive 编辑器支持 IntelliSense。The Hive editor supports IntelliSense. 用于 Visual Studio 的 Data Lake 工具支持在编辑 Hive 脚本时加载远程元数据。Data Lake Tools for Visual Studio supports loading remote metadata when you edit your Hive script. 例如,如果键入 SELECT * FROM,则 IntelliSense 会列出所有建议的表名称。For example, if you type SELECT * FROM, IntelliSense lists all the suggested table names. 在指定表名称后,IntelliSense 会列出列名称。When a table name is specified, IntelliSense lists the column names. 这些工具支持大多数 Hive DML 语句、子查询和内置 UDF。The tools support most Hive DML statements, subqueries, and built-in UDFs.

    IntelliSense 示例 1,Hive 临时查询,HDInsight 群集,Visual Studio

    IntelliSense 示例 2,Hive 临时查询,HDInsight 群集,Visual Studio

    Note

    IntelliSense 只建议 HDInsight 工具栏中所选群集的元数据。IntelliSense suggests only the metadata of the cluster that is selected in the HDInsight toolbar.

    下面是可以使用的示例查询:Here is a sample query that you can use:

    SELECT devicemodel, COUNT(devicemodel) AS deviceCount
    FROM hivesampletable
    GROUP BY devicemodel
    ORDER BY devicemodel
    
  3. 选择执行模式:Choose the execution mode:

    • 交互式Interactive

      在第一个下拉列表中选择“交互式”,然后选择“执行”。 In the first drop-down list, choose Interactive, and then select Execute.

      交互模式,Hive 临时查询,HDInsight 群集,Visual Studio

    • 批处理Batch

      在第一个下拉列表中选择“批处理”,然后选择“提交”(或选择“提交”旁边的下拉图标,然后选择“高级”)。 In the first drop-down list, choose Batch, and then select Submit (or select the drop-down icon next to Submit and choose Advanced).

      批处理模式,Hive 临时查询,HDInsight 群集,Visual Studio

      如果选择高级提交选项,则会显示“提交脚本”对话框。 If you select the advanced submit option, the Submit Script dialog box appears. 配置脚本的“作业名称”、“参数”、“其他配置”和“状态目录”。 Configure the Job Name, Arguments, Additional Configurations, and Status Directory for the script.

      “提交脚本”对话框,Hive 临时查询,HDInsight 群集,Visual Studio

      Note

      无法将批提交到 Interactive Query 群集。You can't submit batches to Interactive Query clusters. 必须使用交互模式。You must use interactive mode.

创建 Hive 应用程序Create a Hive application

若要创建并运行 Hive 解决方案,请执行以下操作:To create and run a Hive solution:

  1. 在菜单栏中,选择“文件” > “新建” > “项目”。 From the menu bar, choose File > New > Project.

  2. 在“创建新项目”窗口中,选择搜索框并键入 HiveIn the Create a new project window, select the search box and type Hive. 然后依次选择“Hive 应用程序”、“下一步”。 Then choose Hive Application and select Next.

  3. 在“配置新项目”窗口中输入一个项目名称,选择或创建项目的位置,然后选择“创建”。 In the Configure your new project window, enter a Project name, select or create the project Location, and then select Create.

    新建 Hive 应用程序,“配置新项目”窗口,HDInsight Visual Studio

  4. 在“解决方案资源管理器”中,双击“Script.hql”将该脚本打开。 In Solution Explorer, double-click Script.hql to open the script.

查看作业摘要和输出View job summary and output

作业摘要根据选择的是“批处理”还是“交互式”模式而略有不同。 The job summary varies slightly between Batch and Interactive mode.

Hive 作业摘要窗口,批处理和交互模式,Visual Studio

使用“刷新”图标更新状态,直到作业状态更改为“已完成”。 Use the Refresh icon to update the status until the job status changes to Finished.

  • 如需“批处理”模式下的作业详细信息,请选择底部的链接以查看“作业查询”、“作业输出”、“作业日志”或“查看 Yarn 日志”。 For the job details from Batch mode, select the links at the bottom to see the Job Query, Job Output, or Job Log, or to View Yarn Logs.

  • 如需“交互式”模式下的作业详细信息,请查看“输出”和“HiveServer2 输出”窗格。 For the job details from Interactive mode, see the Output and HiveServer2 Output panes.

    Hive 交互式作业输出,HDInsight 群集,Visual Studio

查看作业图View job graph

目前,仅显示使用 Tez 作为执行引擎的 Hive 作业的作业图。Currently, job graphs are only shown for Hive jobs that use Tez as the execution engine. 有关启用 Tez 的详细信息,请参阅 Azure HDInsight 中的 Apache Hive 和 HiveQL 是什么?For information about enabling Tez, see What is Apache Hive and HiveQL on Azure HDInsight?. 另请参阅使用 Apache Tez 而不是 Map ReduceSee also, Use Apache Tez instead of Map Reduce.

若要查看顶点中的所有运算符,请双击作业图的相应顶点。To view all the operators inside the vertex, double-click the vertices of the job graph. 也可通过指向特定运算符来查看该运算符的更多详细信息。You can also point to a specific operator to see more details about the operator.

即使已将 Tez 指定为执行引擎,但如果未启动 Tez 应用程序,则也可能不会显示作业图。Even if Tez is specified as the execution engine, the job graph may not appear if no Tez application is launched. 出现这种情况的可能原因是作业不包含 DML 语句,或者在未启动 Tez 应用程序的情况下 DML 语句可以返回。This situation might occur because the job doesn't contain DML statements, or because the DML statements can return without launching a Tez application. 例如,SELECT * FROM table1 不会启动 Tez 应用程序。For example, SELECT * FROM table1 won't launch the Tez application.

Apache Hive 作业图,Visual Studio

查看任务执行详细信息View task execution detail

在作业图中,可以选择“任务执行详细信息”获取 Hive 作业的结构化和可视化信息。 From the job graph, you can select Task Execution Detail to get structured and visualized information for Hive jobs. 还可以获取更多的作业详细信息。You may also get more job details. 如果出现性能问题,可以使用此视图来获取该问题的更多详细信息。If performance issues occur, you can use the view to get more details about the issue. 例如,可以检索每个任务的运行方式和详细信息(数据读取/写入、计划/开始/结束时间,等等),For example, you may retrieve information about how each task operates and detailed information about each task (data read/write, schedule/start/end time, and more). 以便根据可视化信息优化作业配置或系统体系结构。Use the information to tune job configurations or system architecture based on the visualized information.

任务执行视图窗口,Data Lake Visual Studio Tools

查看 Hive 作业View Hive jobs

可以查看作业查询、作业输出、作业日志和 Hive 作业的 Yarn 日志。You can view job queries, job output, job logs, and Yarn logs for Hive jobs.

在最新版本的工具中,可以通过收集和显示 Yarn 日志来查看 Hive 作业的内容。In the most recent release of the tools, you can see what’s inside your Hive jobs by collecting and surfacing Yarn logs. Yarn 日志有助于调查性能问题。A Yarn log can help you investigating performance issues. 有关 HDInsight 如何收集 Yarn 日志的详细信息,请参阅访问 Apache Hadoop YARN 应用程序日志For more information about how HDInsight collects Yarn logs, see Access Apache Hadoop YARN application logs.

若要查看 Hive 作业,请执行以下操作:To view Hive jobs:

  1. 右键单击某个 HDInsight 群集,并选择“查看作业”。 Right-click an HDInsight cluster, and select View Jobs.

    查看作业,Apache Hive,HDInsight 群集,Visual Studio

    此时会显示群集上运行的 Hive 作业的列表。A list of the Hive jobs that ran on the cluster appears.

  2. 选择作业。Select a job. 在“Hive 作业摘要”窗口中,选择以下链接之一: In the Hive Job Summary window, select one of the following links:

    • 作业查询Job Query
    • 作业输出Job Output
    • 作业日志Job Log
    • Yarn 日志Yarn Log

运行 Apache Pig 脚本Run Apache Pig scripts

  1. 在菜单栏中,选择“文件” > “新建” > “项目”。 From the menu bar, choose File > New > Project.

  2. 在“开始”窗口中,选择搜索框并输入 PigIn the Start window, select the search box and enter Pig. 然后依次选择“Pig 应用程序”、“下一步”。 Then select Pig Application and select Next.

  3. 在“配置新项目”窗口输入一个项目名称,然后选择或创建项目的位置In the Configure your new project window, enter a Project name, and select or create a Location for the project. 然后选择“创建” 。Then select Create.

  4. 在 IDE 的“解决方案资源管理器”窗格中,双击“Script.pig”打开脚本。 In the IDE Solution Explorer pane, double-click Script.pig to open the script.

反馈和已知问题Feedback and known issues

  • 解决了以 null 值开头的结果不会显示的问题。An issue in which results that are started with null values aren't shown has been fixed. 如果受此问题困扰,请与支持团队联系。If you're blocked on this issue, contact the support team.
  • Visual Studio 创建的 HQL 脚本会根据用户的本地区域设置进行编码。The HQL script that Visual Studio creates is encoded, depending on the user’s local region setting. 如果以二进制文件形式将脚本上传到群集,脚本将无法正常执行。The script doesn't execute correctly if you upload the script to a cluster as a binary file.

后续步骤Next steps

本文介绍了如何使用用于 Visual Studio 的 Data Lake 工具包从 Visual Studio 连接到 HDInsight 群集,In this article, you learned how to use the Data Lake Tools for Visual Studio package to connect to HDInsight clusters from Visual Studio. 以及如何运行 Hive 查询。You also learned how to run a Hive query. 有关详细信息,请参阅以下文章:For more information, see these articles: